Revit: Double-clicking RVT file does not open project in expected version

Revit: Double-clicking RVT file does not open project in expected version

Revit: Double-clicking RVT file does not open project in expected version


Issue:

When double-clicking an RVT file, the project doesn’t open in the desired version of Revit but in a different release.

Cause:

Windows is configured to use a different program for RVT files than expected/desired.

Solution:

To assign the desired version of Revit to open when double-clicking the RVT file, do one of the following:
 

Use the “Open with” option to choose a different program for that file type

  1. Start Revit as an administrator to give Revit the ability to modify the default setting:
    1. Right-click on the Revit Desktop Shortcut that you want to open RVT files.
    2. Select Run as Administrator.
  1. Use “Open with” to change the default:
    1. With Revit still open, right-click a Revit model and click “Open with” > “Choose another app”



  2. Check the box “Always use this app to open .rvt files.
  3. Click the “More Apps” option.
  4. Scroll to the bottom of the list, and click “Look for another app on this PC”.
  5. Browse to the location of the Revit.exe (by default, it would be C:\Program Files\Autodesk\Revit <Version>).
  6. Select Revit.exe and click Open.


Uninstall Revit associated with the RVT file

If the previous suggestion does not resolve the issue:
  1. Uninstall the Revit version that opens the RVT file by default. (RVT files should become unassociated.)
  2. Uninstall the desired version of default Revit.
  3. Install the desired version of Revit.
  4. (optionally) reinstall the version of Revit previously associated with the RVT file.